Estructura de Repetición

Comienza Ya. Es Gratis
ó regístrate con tu dirección de correo electrónico
Rocket clouds
Estructura de Repetición por Mind Map: Estructura de Repetición

1. Ejemplo ciclo has mientras calcular la suma de los números naturales desde1 hasta n

1.1. Inicio

1.2. Entero i,n,suma

1.3. Leer(n)

1.4. i=1

1.5. Suma=0

1.6. Hacer

1.7. Suma=suma+i

1.8. i=i+1

1.9. Mientras(i<=n)

1.10. Escribir (suma)

1.11. Fin

2. Ejemplo cicló mientras Calcular la suma de Los números naturales desde 1 hasta n. Inicio Entero i,n, suma Leer(n) i=1 Suma=0 Mientras(i<=n) Suma=suma+i i=i+1 Fin_mientras Escribir(suma) Fin

2.1. Ciclo Para Leer 20 números e imprimir cuáles son positivos, cuántos son negativos y cuántos son neutros. Inicio cn=0 cp=0 cneg=0 Parax =1 hasta 20 hacer Leer num Sin num =0 entonces cn= cn+1 Si no Si num >0 entonces cp=cp+1 Sino cneg=cneg +1 Fin-si Fin-si Fin-para Imprimir cn,cp,cneg Fin.

3. REPITA PARA Se utiliza para repetir una sentencia o grupo de sentencias un número fijo de veces. REPITA PARA  variable_de_control:= valor_inicial  HASTA valor_final    Sentencia 1;    Sentencia 2; FIN RP • REPETIR HASTA Se utiliza para repetir una sentencia o grupo de sentencias hasta que una condición especificada sea verdadera. Repetir     Sentencia 1;     Sentencia 2;     ........     Sentencia n; hasta Condición; • REPITA MIENTRAS Se utiliza para repetir una sentencia o grupo de sentencias mientras una condición especificada sea verdadera. Repita Mientras  Condición  se cumpla haga     Sentencia 1;     Sentencia 2;     ........     Sentencia n; fin rm

4. Mientras Que<condición> Acción 1 Acción 2 . . Acción N Fin mientras

5. Instrucción1 Instrucción 2 Instrucción n Repetir mientras [condición]

6. Repita Acción 1 Acción 2 . . Acción N Hasta<condición >

7. Esta estructura ejecuta las acciones del cuerpo del bucle un numero especifico de veces, y de modo automatico controla el numero de iteraciones o pasos.

8. Cuales son las estructuras de repetición